杭电 Tian Ji -- The Horse Racing
更新时间:2023-05-18 01:02:01 阅读量: 实用文档 文档下载
- 杭电推荐度:
- 相关推荐
杭电赛马题题解
杭电 Tian Ji -- The Horse Racing
Tian Ji -- The Horse Racing
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 3 Accepted Submission(s) : 1
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Here is a famous story in Chinese history.
"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."
"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."
"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."
"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."
"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"
hdu <wbr>1052 <wbr>Tian <wbr>Ji <wbr>-- <wbr>The <wbr>Horse <wbr>Racing
Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...
However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.
In this problem, you are asked to write a program to solve this special case of matching problem.
Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, wh
ich is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on th
杭电赛马题题解
e third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
Sample Input
3
92 83 71
95 87 74
2 20 20
20 20
2 2
0 19
22 18
0
Sample Output
200
0
0
终于遇到一道值得题解报告的题了,这是道贪心的题,在杭电提交了13次10次是WA, 仔细想想,觉得还是思考的方向不对后来百度了下终于大彻大悟,百度上的基本是用C++实现,自己用C语言写了个,先来算法吧:
题目大意:田忌和国王赛马,给出马的数量n,然后是田忌的n匹马,国王的n匹马。问田忌最多可以赢得多少比赛(一场200块)。
因为比赛的时候,是国王先出马,然后田忌再出,田忌有主动权上的优势。
先对田忌和国王的马进行排序。
贪心的策略:
一、当田忌最快的马比国王最快的马快时,用田忌最快的马赢国王最快的马。
二、当田忌最快的马比国王最快的马慢时,用田忌最慢的马输给国王最快的马。
三、当田忌最快的马跟国王最快的马一样快时,分情况:
1、当田忌最慢的马比国王最慢的马快,那么用田忌最慢的马赢国王最慢的马
2、当田忌最慢的马比国王最慢的马慢,那么用田忌最慢的马输给国王最快的马
3、当田忌最慢的马跟国王最慢的马相等的时候,用田忌最慢的马跟国王最快的马比
下面是网上的证明:
证明一、:假设现在国王最快的马是K,田忌最快的马是T,如果存在一种更优的比赛策略,让T的对手不是K,而使得田忌赢更多的钱的话,那么设此时K的对手是t,T的对手是k:( T>K &&T>t && K>k)
1、 若t>K,则有T>k,t>K。这个结果和T>K,t>k是相同的。
2、 若k<t≤K,则有T>k,t≤K。这个结果不如T>K,t>k来得优秀。
3、 若t≤k≤K,则有T>k,t≤K。这个结果和T>K,t≤k是相同的。
由此可知,交换各自对手后,一定不会使得结果变劣,那么假设是不成立的。
证明二、:因为田忌最快的马比国王最快的马慢,所以田忌所有的马都比国王最快的马慢,也就是说此时田忌的所有马都赢不了国王的马,而出于贪心的思想,应该保留相比之下更快的马,因此用最慢的马去输一定不会比用别的马去输来得劣。
其实上面这两个很容易就想得到,最难的是相等的时候。因为不可以直接让田忌最快的马跟国王最快的马打平,或者直接用最慢的马去输给国王最快的马。(存在反例)
下面是我的代码:
#include&l
t;stdio.h>
void swap(int *a,int *b)
{
int temp= *a;
(*a) = (*b);
(*b) = temp;
}
int main()
{
int n,i,k,mina,maxa,sum,maxb,minb;
杭电赛马题题解
int a[1010],b[1010];
while(scanf("%d",&n)!=EOF&&n)
{
for(i = 0;i < n; i++)
scanf("%d",&a[i]);
for(i = 0;i < n; i++)
scanf("%d",&b[i]);
for(i = n-1 ;i >= 0; --i)
{
for(k = 0;k < i; k++)
{
if(a[i] < a[k])
swap(&a[i],&a[k]);
if(b[i] < b[k] )
swap(&b[i],&b[k]);
}
}
k=0;
mina=0;
minb=0;
maxa=n-1;
maxb=n-1;
for(i = 0; i < n; i ++)
{
if(a[maxa] > b[maxb])
{
maxa--;
maxb--;
k++;
}
else if(a[maxa] < b[maxb])
{
mina++;
maxb--;
k--;
}
else
{
if(a[mina] < b[minb])
{
maxb--;
mina++;
k--;
}
else if(a[mina] > b[minb])
{
mina++;
minb++;
k++;
}
else
{
if(a[mina] < b[maxb])
{
maxb--;
mina++;
k--;
}
}
}
}
sum = 200 * k;
printf("%d\n",sum);
}
return 0;
}
正在阅读:
杭电 Tian Ji -- The Horse Racing05-18
工程机械钻孔灌注桩施工技术-工程机械论文-工程论文05-04
刍议电气技术的融合发展01-06
职业健康知识培训讲义 - 图文10-09
定义域、值域高考总复习07-18
关于读书心得的随笔作文11-20
SD30MT交流伺服说明书 - 图文03-11
社会工作实务--考点整理09-25
计量经济学练习题05-25
个人房屋租赁合同范本简单02-24
- 教学能力大赛决赛获奖-教学实施报告-(完整图文版)
- 互联网+数据中心行业分析报告
- 2017上海杨浦区高三一模数学试题及答案
- 招商部差旅接待管理制度(4-25)
- 学生游玩安全注意事项
- 学生信息管理系统(文档模板供参考)
- 叉车门架有限元分析及系统设计
- 2014帮助残疾人志愿者服务情况记录
- 叶绿体中色素的提取和分离实验
- 中国食物成分表2020年最新权威完整改进版
- 推动国土资源领域生态文明建设
- 给水管道冲洗和消毒记录
- 计算机软件专业自我评价
- 高中数学必修1-5知识点归纳
- 2018-2022年中国第五代移动通信技术(5G)产业深度分析及发展前景研究报告发展趋势(目录)
- 生产车间巡查制度
- 2018版中国光热发电行业深度研究报告目录
- (通用)2019年中考数学总复习 第一章 第四节 数的开方与二次根式课件
- 2017_2018学年高中语文第二单元第4课说数课件粤教版
- 上市新药Lumateperone(卢美哌隆)合成检索总结报告
- Racing
- Horse
- 杭电
- Tian
- Ji
- 计算机组装与维护实训报告4
- 2011朝阳初三二模化学
- 定稿安全知识竞赛准备方案
- 2007erp制造业白皮书
- 空间缆索悬索桥的主缆线形分析_罗喜恒
- 国家安全与大学生使命
- 3.3-减法的运算性质
- 常用化工英文缩写与中文名对照
- ANSYS拱坝建模命令流
- 列方程或方程组解应用题
- Delphi 编写ActiveX控件(OCX控件)的知识和样例
- 广西河池市两学一做专题考试题库
- 银川新华百货商店股份有限公司2004年年度报告
- 1-2月份国民经济主要指标数据
- 废橡胶轮胎提取炭黑和轮胎油的可行性分析报告
- 20110222 项目暖场活动方案提纲
- 中国有机着色剂市场发展现状及竞争策略分析报告(2015-2020)
- Auto CAD2007 第8章 绘制与编辑复杂二维图形对象
- 四川省绵阳市2014届高三第二次诊断性考试数学(理)试题 Word版含答案
- 创先争优活动开展情况总结1